Improve Security by Keeping Your OS and Web Browser Up-to-Date – Support for IE 7, 8, & 9 is Ending

Out dated operating systems (OS) and web browsers do not contain the lastest security updates, which may put your data at risk. Support for Internet Explorer 7, 8, & 9 is ending. Please see the blog post for more information.

The Volgistics system is automatically updated to include the latest new features and important security updates so you never need to worry about Volgistics being out-of-date. However, if your web browser (which in turn uses your operating system) is not up-to-date, your system may be at risk.

As new threats are discovered, web browsers and operating systems (OS) are continually updated to protect users. But, if you do not update regularly, you’re still vulnerable! The risk in this case is not limited to Volgistics, but extends to any Internet activity you engage in such as online banking or shopping.

The best course of action is to enable automatic updates for your OS and web browser. If you’re not able to use automatic updates for your web browser, you can find a handy resource to make regular updates here. You will need to use local resources to learn about making updates to your OS.

These simple precautions will protect the vast majority of Volgistics customers. However, if you’re still using Windows XP or Vista as your OS, things are much more complicated because of Microsoft’s lifecycle for support. Microsoft ended support for Windows XP in April of 2014 and support for older versions of Internet Explorer in January 2016. Microsoft will end support for Windows Vista in April of 2017.

Because Windows XP uses Internet Explorer 7 and 8, and there will be increasing security vulnerabilities due to Microsoft dropping support, Volgistics will be ending support for these browsers in the near future. This means that if you’re currently using Windows XP, you will need to use a supported OS in order to access Volgistics instead. This includes access by System Operators, access by volunteers and Coordinators through VicNet, and the volunteer sign-in stations that run VicTouch.

Later, Volgistics will end support for Internet Explorer 9 so Windows Vista users will need to switch to a supported OS to access the system.

We understand that volunteer departments and not-for-profit organizations may have limited IT budgets and we empathize with any hardships that updating the OS on computers cause. However, as manufacturers such as Microsoft end support for older systems we are left with no choice but to end support also so your information is safe. If you have questions about the end of support for Internet Explorer, please submit a help inquiry and we’ll be happy to assist you.

This entry was posted in Feature Updates, News and tagged , , . Bookmark the permalink.

Leave a Reply